import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$";
final String string = "::\n"
+ "::123\n"
+ "::123:456\n"
+ "::123:456:789\n"
+ "::123:456:789:abc:def:6666\n"
+ "::123:456:789:abc:def:6666:7\n\n"
+ "123::456\n"
+ "123::456:789\n"
+ "123::456:789:abc\n"
+ "123::456:789:abc:def\n"
+ "123::456:789:abc:def:6\n"
+ "123::456:789:abc:def:6:7\n\n"
+ "123:456::789\n"
+ "123:456::789:abc\n"
+ "123:456::789:abc:def\n"
+ "123:456::789:abc:def:6666\n"
+ "123:456::789:abc:def:6666:7\n\n"
+ "123:456:789::abc\n"
+ "123:456:789::abc:def\n"
+ "123:456:789::abc:def:6666\n"
+ "123:456:789::abc:def:6666:7\n\n"
+ "123:456:789:abc::def\n"
+ "123:456:789:abc::def:6666\n"
+ "123:456:789:abc::def:66666:7\n\n"
+ "123:456:789:abc:def::6666\n"
+ "123:456:789:abc:def::6666:7\n\n"
+ "123:456:789:abc:def:6666::\n"
+ "123:456:789:abc:def::\n"
+ "123:456:789:abc::\n"
+ "123:456:789::\n"
+ "123:456::\n"
+ "123::\n\n"
+ "123::456:789:abc:def:6666\n"
+ "123:456:789:abc:def:6666:7\n"
+ "123::456::abc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}