import Foundation
let pattern = #"TXN[a-zA-Z0-9]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TXNIDVLDYLGREJF2JI
TXNIDVLDJFRHOUPBVI
TXNIDVLDNEDQC2WUAH
TXNIDVLDYEATXQ5GG6
TXNIDVLDFIGZO5YUNT
TXNIDVLDFIGZ05YUNT
TXNIDVLDIPTI04G8UV
TXNIDVLD08ZFNV4CMY
TXNVIBHCLMS572889
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)