using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TXN[a-zA-Z0-9]*";
string input = @"TXNIDVLDYLGREJF2JI
TXNIDVLDJFRHOUPBVI
TXNIDVLDNEDQC2WUAH
TXNIDVLDYEATXQ5GG6
TXNIDVLDFIGZO5YUNT
TXNIDVLDFIGZ05YUNT
TXNIDVLDIPTI04G8UV
TXNIDVLD08ZFNV4CMY
TXNVIBHCLMS572889
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}