package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TXN[a-zA-Z0-9]*`)
var str = `TXNIDVLDYLGREJF2JI
TXNIDVLDJFRHOUPBVI
TXNIDVLDNEDQC2WUAH
TXNIDVLDYEATXQ5GG6
TXNIDVLDFIGZO5YUNT
TXNIDVLDFIGZ05YUNT
TXNIDVLDIPTI04G8UV
TXNIDVLD08ZFNV4CMY
TXNVIBHCLMS572889
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}