#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)TXN[a-zA-Z0-9]*"
Local $sString = "TXNIDVLDYLGREJF2JI" & @CRLF & _
"TXNIDVLDJFRHOUPBVI" & @CRLF & _
"TXNIDVLDNEDQC2WUAH" & @CRLF & _
"TXNIDVLDYEATXQ5GG6" & @CRLF & _
"TXNIDVLDFIGZO5YUNT" & @CRLF & _
"TXNIDVLDFIGZ05YUNT" & @CRLF & _
"TXNIDVLDIPTI04G8UV" & @CRLF & _
"TXNIDVLD08ZFNV4CMY" & @CRLF & _
"TXNVIBHCLMS572889" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")