const regex = /TXN[a-zA-Z0-9]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('TXN[a-zA-Z0-9]*', 'gm')
const str = `TXNIDVLDYLGREJF2JI
TXNIDVLDJFRHOUPBVI
TXNIDVLDNEDQC2WUAH
TXNIDVLDYEATXQ5GG6
TXNIDVLDFIGZO5YUNT
TXNIDVLDFIGZ05YUNT
TXNIDVLDIPTI04G8UV
TXNIDVLD08ZFNV4CMY
TXNVIBHCLMS572889
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}