import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TXN[a-zA-Z0-9]*";
final String string = "TXNIDVLDYLGREJF2JI\n"
+ "TXNIDVLDJFRHOUPBVI\n"
+ "TXNIDVLDNEDQC2WUAH\n"
+ "TXNIDVLDYEATXQ5GG6\n"
+ "TXNIDVLDFIGZO5YUNT\n"
+ "TXNIDVLDFIGZ05YUNT\n"
+ "TXNIDVLDIPTI04G8UV\n"
+ "TXNIDVLD08ZFNV4CMY\n"
+ "TXNVIBHCLMS572889\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}