// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(1) (\d{5})([US ]) (\d{2})(\d{3})([A-Z ]{1,3}) (\d{2})(\d.{11}) ([-].\d{8}) ([-+ ]\d{5}[-+ ]\d) ([-+ ]\d{5}[-+]\d) ([0-4]) ([ \d]{4})(\d)
(2) (\d{5}) ([ \d]{3}.[\d ]{4}) ([ \d]{3}.[ \d]{4}) (\d{7}) ([ \d]{3}.[\d ]{4}) ([ \d]{3}.[\d ]{4}) ([ \d]{2}.[\d ]{8})([ \d]{5})(\d)").unwrap();
let string = "1 25544S 98067A 98324.28472222 -.00003657 11563-4 00000+0 0 10
2 25544 51.5908 168.3788 0125362 86.4185 359.7454 16.05064833 05";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}