const regex = /(1) (\d{5})([US ]) (\d{2})(\d{3})([A-Z ]{1,3}) (\d{2})(\d.{11}) ([-].\d{8}) ([-+ ]\d{5}[-+ ]\d) ([-+ ]\d{5}[-+]\d) ([0-4]) ([ \d]{4})(\d)
(2) (\d{5}) ([ \d]{3}.[\d ]{4}) ([ \d]{3}.[ \d]{4}) (\d{7}) ([ \d]{3}.[\d ]{4}) ([ \d]{3}.[\d ]{4}) ([ \d]{2}.[\d ]{8})([ \d]{5})(\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(1) (\\d{5})([US ]) (\\d{2})(\\d{3})([A-Z ]{1,3}) (\\d{2})(\\d.{11}) ([-].\\d{8}) ([-+ ]\\d{5}[-+ ]\\d) ([-+ ]\\d{5}[-+]\\d) ([0-4]) ([ \\d]{4})(\\d)
(2) (\\d{5}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{3}.[ \\d]{4}) (\\d{7}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{2}.[\\d ]{8})([ \\d]{5})(\\d)', '')
const str = `1 25544S 98067A 98324.28472222 -.00003657 11563-4 00000+0 0 10
2 25544 51.5908 168.3788 0125362 86.4185 359.7454 16.05064833 05`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}