import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(1) (\\d{5})([US ]) (\\d{2})(\\d{3})([A-Z ]{1,3}) (\\d{2})(\\d.{11}) ([-].\\d{8}) ([-+ ]\\d{5}[-+ ]\\d) ([-+ ]\\d{5}[-+]\\d) ([0-4]) ([ \\d]{4})(\\d)\n"
+ "(2) (\\d{5}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{3}.[ \\d]{4}) (\\d{7}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{3}.[\\d ]{4}) ([ \\d]{2}.[\\d ]{8})([ \\d]{5})(\\d)";
final String string = "1 25544S 98067A 98324.28472222 -.00003657 11563-4 00000+0 0 10\n"
+ "2 25544 51.5908 168.3788 0125362 86.4185 359.7454 16.05064833 05";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}