re = /time=(\d+\-\d+\-\d+\s+\d+:\d+:\d+)\|action=(\w+)\|[f_name=(\S*)]?\|has_accounting=0/
str = 'time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0
time=2014-07-21 16:15:57|action=reject|has_accounting=0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end