import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "time=(\\d+\\-\\d+\\-\\d+\\s+\\d+:\\d+:\\d+)\\|action=(\\w+)\\|[f_name=(\\S*)]?\\|has_accounting=0";
final String string = "time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0\n"
+ "time=2014-07-21 16:15:57|action=reject|has_accounting=0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}