use strict;
my $str = 'time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0
time=2014-07-21 16:15:57|action=reject|has_accounting=0';
my $regex = qr/time=(\d+\-\d+\-\d+\s+\d+:\d+:\d+)\|action=(\w+)\|[f_name=(\S*)]?\|has_accounting=0/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}