const regex = new RegExp('time=(\\d+\\-\\d+\\-\\d+\\s+\\d+:\\d+:\\d+)\\|action=(\\w+)\\|[f_name=(\\S*)]?\\|has_accounting=0', '')
const str = `time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0
time=2014-07-21 16:15:57|action=reject|has_accounting=0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}