$re = '/time=(\d+\-\d+\-\d+\s+\d+:\d+:\d+)\|action=(\w+)\|[f_name=(\S*)]?\|has_accounting=0/';
$str = 'time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0
time=2014-07-21 16:15:57|action=reject|has_accounting=0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);