package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`time=(\d+\-\d+\-\d+\s+\d+:\d+:\d+)\|action=(\w+)\|[f_name=(\S*)]?\|has_accounting=0`)
var str = `time=2014-07-21 16:15:55|action=accept|f_name=eth3.2|has_accounting=0
time=2014-07-21 16:15:57|action=reject|has_accounting=0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}