import Foundation
let pattern = #"^The\.Walking\.Dead\.S06.+VOSTFR.+x264"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}