$re = '/^The\.Walking\.Dead\.S06.+VOSTFR.+x264/i';
$str = 'The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);