const regex = /^The\.Walking\.Dead\.S06.+VOSTFR.+x264/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^The\\.Walking\\.Dead\\.S06.+VOSTFR.+x264', 'i')
const str = `The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}