package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^The\.Walking\.Dead\.S06.+VOSTFR.+x264`)
var str = `The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}