#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^The\.Walking\.Dead\.S06.+VOSTFR.+x264"
Local $sString = "The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")