re = /^The\.Walking\.Dead\.S06.+VOSTFR.+x264/i
str = 'The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY'
# Print the match result
str.match(re) do |match|
puts match.to_s
end