re = /(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))/
str = 'skdsd .5 cups'
subst = '\\{3}\\{4}1/2\\{4}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result