# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))/\{3}\{4}1\/2\{4}/;t' <<< "skdsd .5 cups"