using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))";
string substitution = @"\{3}\{4}1/2\{4}";
string input = @"skdsd .5 cups";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}