const regex = new RegExp('(0\\.5)|(\\.5)|([0-9]*?)\\.5((?(1)| ))', '')
const str = `skdsd .5 cups`;
const subst = `\{3}\{4}1/2\{4}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);