import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0\\.5)|(\\.5)|([0-9]*?)\\.5((?(1)| ))";
final String string = "skdsd .5 cups";
final String subst = "\\{3}\\{4}1/2\\{4}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}