$re = '/(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))/';
$str = 'skdsd .5 cups';
$subst = "\{3}\{4}1/2\{4}";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;