re = /([0-9]|[a-zA-Z]+| )*/
str = 'lucas emanuel agora com espacos varios espacos comp ! iladores
quebra de linha e ! '
# Print the match result
str.match(re) do |match|
puts match.to_s
end