package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]|[a-zA-Z]+| )*`)
var str = `lucas emanuel agora com espacos varios espacos comp ! iladores
quebra de linha e ! `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}