const regex = new RegExp('([0-9]|[a-zA-Z]+| )*', '')
const str = `lucas emanuel agora com espacos varios espacos comp ! iladores
quebra de linha e ! `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}