$re = '/([0-9]|[a-zA-Z]+| )*/';
$str = 'lucas emanuel agora com espacos varios espacos comp ! iladores
quebra de linha e ! ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);