using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]|[a-zA-Z]+| )*";
string input = @"lucas emanuel agora com espacos varios espacos comp ! iladores
quebra de linha e ! ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}