#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9]|[a-zA-Z]+| )*"
Local $sString = "lucas emanuel agora com espacos varios espacos comp ! iladores" & @CRLF & _
"quebra de linha e ! "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")