import Foundation
let pattern = #"Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
jude1:1
jude 1:1
jude1:1-2
judges1:1-2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)