re = /Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b/mi
str = 'jude1:1
jude 1:1
jude1:1-2
judges1:1-2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end