$re = '/Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b/mi';
$str = 'jude1:1
jude 1:1
jude1:1-2
judges1:1-2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);