const regex = /Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Jude ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b|\\bjud ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b|\\bjd ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b', 'gmi')
const str = `jude1:1
jude 1:1
jude1:1-2
judges1:1-2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}