import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Jude ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b|\\bjud ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b|\\bjd ?\\d{1,3}:\\d{1,3}(-\\d{1,3})?\\b";
final String string = "jude1:1\n"
+ "jude 1:1\n"
+ "jude1:1-2\n"
+ "judges1:1-2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}