using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b";
string input = @"jude1:1
jude 1:1
jude1:1-2
judges1:1-2
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}