// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?\d+(?:\.\d+)?$").unwrap();
let string = "+0.0
0.0
-00.00
-000.000
10
5
-7.9
-10.88765444
-1234566.86654432
12355.79795763649
10..2
++1231
--99.0
--444..555
.99
7.
888888...4
984hb7822
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}