#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?\d+(?:\.\d+)?$"
Local $sString = "+0.0" & @CRLF & _
"0.0" & @CRLF & _
"-00.00" & @CRLF & _
"-000.000" & @CRLF & _
"10" & @CRLF & _
"5" & @CRLF & _
"-7.9" & @CRLF & _
"-10.88765444" & @CRLF & _
"-1234566.86654432" & @CRLF & _
"12355.79795763649" & @CRLF & _
"" & @CRLF & _
"10..2" & @CRLF & _
"++1231" & @CRLF & _
"--99.0" & @CRLF & _
"--444..555" & @CRLF & _
".99" & @CRLF & _
"7." & @CRLF & _
"888888...4" & @CRLF & _
"984hb7822" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")