package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d+(?:\.\d+)?$`)
var str = `+0.0
0.0
-00.00
-000.000
10
5
-7.9
-10.88765444
-1234566.86654432
12355.79795763649
10..2
++1231
--99.0
--444..555
.99
7.
888888...4
984hb7822
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}