import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?\\d+(?:\\.\\d+)?$";
final String string = "+0.0\n"
+ "0.0\n"
+ "-00.00\n"
+ "-000.000\n"
+ "10\n"
+ "5\n"
+ "-7.9\n"
+ "-10.88765444\n"
+ "-1234566.86654432\n"
+ "12355.79795763649\n\n"
+ "10..2\n"
+ "++1231\n"
+ "--99.0\n"
+ "--444..555\n"
+ ".99\n"
+ "7.\n"
+ "888888...4\n"
+ "984hb7822\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}