using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d+(?:\.\d+)?$";
string input = @"+0.0
0.0
-00.00
-000.000
10
5
-7.9
-10.88765444
-1234566.86654432
12355.79795763649
10..2
++1231
--99.0
--444..555
.99
7.
888888...4
984hb7822
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}