re = /^[+-]?\d+(?:\.\d+)?$/m
str = '+0.0
0.0
-00.00
-000.000
10
5
-7.9
-10.88765444
-1234566.86654432
12355.79795763649
10..2
++1231
--99.0
--444..555
.99
7.
888888...4
984hb7822
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end