// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^http(s)?:\/\/(my.|writer.)dek-d.com\/.*\/view(longc)?.php\?id=(\d)*(\&chapter=(\d)*)?$").unwrap();
let string = "https://writer.dek-d.com/view.php?id=1714407&chapter=13";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}