package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^http(s)?:\/\/(my.|writer.)dek-d.com\/.*\/view(longc)?.php\?id=(\d)*(\&chapter=(\d)*)?$`)
var str = `https://writer.dek-d.com/view.php?id=1714407&chapter=13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}