using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s)?:\/\/(my.|writer.)dek-d.com\/.*\/view(longc)?.php\?id=(\d)*(\&chapter=(\d)*)?$";
string input = @"https://writer.dek-d.com/view.php?id=1714407&chapter=13";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}