const regex = /^http(s)?:\/\/(my.|writer.)dek-d.com\/.*\/view(longc)?.php\?id=(\d)*(\&chapter=(\d)*)?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http(s)?:\\\/\\\/(my.|writer.)dek-d.com\\\/.*\\\/view(longc)?.php\\?id=(\\d)*(\\&chapter=(\\d)*)?$', 'gim')
const str = `https://writer.dek-d.com/view.php?id=1714407&chapter=13`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}